SYMBIAN OS SECTION
  -My-Symbian.com-
MAEMO  SECTION
-My-Maemo.com-
MEEGO  SECTION
-My-MeeGo.com-
SOFTWARE STORECONTACT


My-Symbian.com Forums

 
My-Symbian ~ My-Maemo ~ My-MeeGo
Symbian & Linux based Communicator and Smartphone Info Center
The Oldest Symbian Community Website - Since 1999
 
 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   RulesRules   Log inLog in 
Lightweight, simplified version of the forumsMobile version
Darwin award for this one I think

 
Post new topic   Reply to topic    My-Symbian ~ My-Maemo ~ My-MeeGo Forum Index -> Maemo 5 Fremantle
View previous topic :: View next topic  
Author Message
ronski
Forum Newbie
Forum Newbie

Please add your avatar!

Joined: 30 Sep 2011

Posts: 4

Thanks received:
0 in 0 posts
Thanks given: 0


Phone: N900

PostPosted: Friday, 30.Sep.2011 00:54    Post subject: Darwin award for this one I think   Reply with quote   

Ok don't laugh at the crazy noob

Was trying to recover a deleted photo so I ran Photorec. Turned out to be a big mistake as I very stupidly allowed it to save files in the rootfs Embarassed

I can see them with midnight commander but it won't let me delete them - I'm assuming its not mounted or something and have now read enough to know mounting the root might not be good idea.

Obviously with no rootfs space I have a read-only brick. Am I flashing it or is there something I can do to delete my folder of recovered image files that's sitting where I really shouldn't have put it!!!!

/recup_dir.1 (ie root)

Oops.
Back to top
Rob1n
Site supporter
Site supporter

Please add your avatar!

Joined: 06 Mar 2008

Posts: 475

Thanks received:
5 in 5 posts
Thanks given: 29


Phone: E90, N800, N900

PostPosted: Friday, 30.Sep.2011 10:54    Post subject:   Reply with quote   

The rootfs has to be mounted or you wouldn't be able to use the phone at all. Are you running midnight commander as the root user or as the normal user? The file permissions may prevent the normal user from deleting them. If you have rootsh installed, then run "root" or "sudo gainroot" to change to the root user.
Back to top
ronski
Forum Newbie
Forum Newbie

Please add your avatar!

Joined: 30 Sep 2011

Posts: 4

Thanks received:
0 in 0 posts
Thanks given: 0


Phone: N900

PostPosted: Friday, 30.Sep.2011 14:27    Post subject:   Reply with quote   

OK - thanks,
Opened terminal window
sudo gainroot (responds "enable RD mode if you want ot break your device". There's no change to the cursor to confirm its now root though.

then:
mc

Permission Denied (13). Same error if I try to move to MyDocs

Now I've realised I must no longer have rootsh installed (I know I did at one point but its obviously not there now). I've got the App Manager working, but it won't install rootsh saying its out of memory. There's plenty space in that partition so it must be rootfs space that's missing. I've tried to unistall some apps, but that won't work either. App manager cannot unistall anything, and resumably I can't do it manually without rootsh !!!!!

Is there any way I can either install rootsh or get root login some other way? Thanks.
Back to top
Rob1n
Site supporter
Site supporter

Please add your avatar!

Joined: 06 Mar 2008

Posts: 475

Thanks received:
5 in 5 posts
Thanks given: 29


Phone: E90, N800, N900

PostPosted: Friday, 30.Sep.2011 17:32    Post subject:   Reply with quote   

You should be able to boot in R&D mode and gain root access there. I'd also check to see whether there's any large files under /tmp you can delete.
Back to top
ronski
Forum Newbie
Forum Newbie

Please add your avatar!

Joined: 30 Sep 2011

Posts: 4

Thanks received:
0 in 0 posts
Thanks given: 0


Phone: N900

PostPosted: Saturday, 01.Oct.2011 00:17    Post subject:   Reply with quote   

nothing larger than 4k in /tmp & anyway I can't delete it without root login Sad

trying to get into R&D mode, but I've got no linux box or mac & http://wiki.maemo.org/R%26D_mode says the windows flasher will not set R&D mode. Ah but there is a flasher built in I find..... but I can't seem to get it to work

/usr/bin/flasher --enable-rd-mode executed on the Xterminal in the phone sends it looking for something attached to USB Confused
Back to top
ronski
Forum Newbie
Forum Newbie

Please add your avatar!

Joined: 30 Sep 2011

Posts: 4

Thanks received:
0 in 0 posts
Thanks given: 0


Phone: N900

PostPosted: Saturday, 01.Oct.2011 02:56    Post subject:   Reply with quote   

update!

ignored the bit about the windows flasher not working & tried it.....it worked Very Happy
sudo gainroot
mc

delete folder in mc

one happy (but tired) boy

first thing I did after unsetting RD mode? reinstalled rootsh! Then removed PhotoRec
Wink

Thanks for all the advice
Back to top
Display posts from previous:   
Post new topic   Reply to topic    My-Symbian ~ My-Maemo ~ My-MeeGo Forum Index -> Maemo 5 Fremantle All times are GMT + 2 Hours
Page 1 of 1

 
Jump to:  
View previous topic :: View next topic


Posting/discussing/exchanging warez/cracks/serial numbers/links to web sites offering such resources and/or any other illegal content
is FORBIDDEN on this forum and results in an immediate BAN.


Symbian and all Symbian-based marks and logos are trade marks of Symbian Software Limited.
This website is not in any way endorsed or supported by Symbian Software Limited.    (C) 2001 My-Symbian.com All Rights Reserved