SYMBIAN OS SECTION
  -My-Symbian.com-
MAEMO  SECTION
-My-Maemo.com-
MEEGO  SECTION
-My-MeeGo.com-
SOFTWARE STORECONTACT


My-Symbian.com Forums

 
My-Symbian ~ My-Maemo ~ My-MeeGo
Symbian & Linux based Communicator and Smartphone Info Center
The Oldest Symbian Community Website - Since 1999
 
 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   RulesRules   Log inLog in 
Lightweight, simplified version of the forumsMobile version
libpcre3 is not installable !!

Go to page
1, 2  Next

 
Post new topic   Reply to topic    My-Symbian ~ My-Maemo ~ My-MeeGo Forum Index -> Maemo 5 Fremantle
View previous topic :: View next topic  
Author Message
mbzadegan
Forum Newbie
Forum Newbie



Joined: 20 Jun 2013

Posts: 12

Thanks received:
0 in 0 posts
Thanks given: 12


Phone: N900

PostPosted: Thursday, 20.Jun.2013 17:16    Post subject: libpcre3 is not installable !!   Reply with quote   

Hi Every body ,

I want to install WireShark but it need libpcre3 and that this file is not installable on my N900 !
how could i install libpcre3 to installing wireshark ?
Back to top
Ketilk
Site supporter
Site supporter

Please add your avatar!

Joined: 19 Dec 2011

Posts: 506

Thanks received:
50 in 45 posts
Thanks given: 6


Phone: Jolla, N9 , N900, N97-mini

PostPosted: Friday, 21.Jun.2013 03:35    Post subject:   Reply with quote   

libpcre3 is available in the standard official repository on N900 called Nokia Applications so it should be installable automatically. The package is called libpcre3 with short description Perl 5 Compatible Regular Expression Library - runtime files.

I am unable to locate it in the application manager GUI because it's a library and not an application, but easily find it with command line client. If you are comfortable with the command line you can open x-terminal and write apt-cache search libpcre3. That will verify it's existence or not.

You want to get this output(command in bold):
Quote:

~ $ apt-cache search libpcre3
libpcre3 - Perl 5 Compatible Regular Expression Library - runtime files


If you don't find it then you will probably need to add that repository again. I don't want to describe how to install it by using root access until I know more about the problem that makes it unavailable. You are connected to the Internet while you install WireShark? If not, then that could be your problem.
Back to top

The following users say THANKS! for this post: mbzadegan

mbzadegan
Forum Newbie
Forum Newbie



Joined: 20 Jun 2013

Posts: 12

Thanks received:
0 in 0 posts
Thanks given: 12


Phone: N900

PostPosted: Friday, 21.Jun.2013 09:27    Post subject:   Reply with quote   

Yes Dear Ketilk,
I'm using N900 only because of lovely command interface I Love You
When i typed apt-cache search libpcre3 as root then did not get any message !
I guess that it occurs because of my country restricted but i run TOR and don't change any thing !
How can i connect to Nokia Main Repository ?
Back to top
Ketilk
Site supporter
Site supporter

Please add your avatar!

Joined: 19 Dec 2011

Posts: 506

Thanks received:
50 in 45 posts
Thanks given: 6


Phone: Jolla, N9 , N900, N97-mini

PostPosted: Friday, 21.Jun.2013 15:55    Post subject:   Reply with quote   

In my/etc/apt/sources.list.d I have a file with .list extension that have this content:
Quote:
deb https://downloads.maemo.nokia.com/fremantle/ssu/apps/ ./
deb https://downloads.maemo.nokia.com/fremantle/ssu/mr0 ./
deb https://downloads.maemo.nokia.com/fremantle1.2/ovi/ ./


There is also a file called /etc/apt/auth with authentication details. Mine have this content
Quote:
machine downloads.maemo.nokia.com
login qa9recEP
password Pat2UGuP
I also found this file when I searched the Internet so it is shared among multiple devices. I am not sure if the password is firmware independent though. Try searching for hildon-application-manager-settings:
apt-cache search hildon-application-manager-settings. If you get hildon-application-manager-settings-standard then I believe my password will work fine. If you get something else I will recommend reinstalling that package. If you get nothing then I am not sure.

You will also find libpcre3 here, but you might want to fix your official repositories anyway.

Remember to refresh you repositories with apt-get update when you have the auth file in place. If that is successful then you will probably be able to install libpre3 automatically as a dependency by either reinstalling WireShark or if WireShark is installed but does not work by using apt-get -f install. Or install manually by using apt-get install libpcre3
Back to top

The following users say THANKS! for this post: mbzadegan

mbzadegan
Forum Newbie
Forum Newbie



Joined: 20 Jun 2013

Posts: 12

Thanks received:
0 in 0 posts
Thanks given: 12


Phone: N900

PostPosted: Saturday, 22.Jun.2013 13:21    Post subject:   Reply with quote   

My /etc/apt/auth have your password originally but still my apt-get update don't update !
anyways ,
I have a socks and proxy account .
How Could i Connect to a proxy or socks server to prevent from nokia boycott and connect to main repositories ?
Help
Back to top
Ketilk
Site supporter
Site supporter

Please add your avatar!

Joined: 19 Dec 2011

Posts: 506

Thanks received:
50 in 45 posts
Thanks given: 6


Phone: Jolla, N9 , N900, N97-mini

PostPosted: Saturday, 22.Jun.2013 15:25    Post subject:   Reply with quote   

I searched the Internet for your problem and if you installed TOR on your N900 it seems like it also added a line to a file called /etc/apt/apt.conf.d/00maemo with proxy information. You might want to edit that file in order to ensure that you have this line also:
Code:
Acquire::https::Proxy "DIRECT";

That line disables the anonymous proxy for the official nokia repositories, but keeps them for any repository that does not use https. I don't know if Nokia blocks you or if it is the proxy that blocks you or both.

I have tried figuring out how to make it work through a proxy, but I think I will have to do a man-in-the-middle attack(to myself) in order to do that and I can't understand how to make it work through TOR. I can't get the proxy to pass through authentication and get access denied.

I didn't have success with either SOCKS-proxy, HTTPS-proxy or HTTP-proxy. I think VPN to an unrestricted area will work, but I haven't tried that.
EDIT: I searched the Internet and changed my post according to the information I found there.

EDIT2: You might want to install the package tsocks, configure the lines under to fit your socks proxy and run tsocks apt-get update. I don't know if it is smart to use apt-get to update the system applications, but you can at least use it for installing libpcre3 with tsocks apt-get install libpcre3
Code:
server = 127.0.0.1
 server_type = 5
 server_port = 9999

If you are using tsocks then you should not have any proxy settings for https transfers in apt. I.e. use Acquire::https::Proxy "DIRECT"; or have no global proxy settings and no proxy settings in /etc/apt/apt.conf.d/
Back to top

The following users say THANKS! for this post: mbzadegan

Ketilk
Site supporter
Site supporter

Please add your avatar!

Joined: 19 Dec 2011

Posts: 506

Thanks received:
50 in 45 posts
Thanks given: 6


Phone: Jolla, N9 , N900, N97-mini

PostPosted: Monday, 24.Jun.2013 21:20    Post subject:   Reply with quote   

I wonder if you can give me a reply? I want to know whether you understood what I wrote, whether it fixed your problem or whether you still have some errors.
Back to top

The following users say THANKS! for this post: mbzadegan

mbzadegan
Forum Newbie
Forum Newbie



Joined: 20 Jun 2013

Posts: 12

Thanks received:
0 in 0 posts
Thanks given: 12


Phone: N900

PostPosted: Tuesday, 25.Jun.2013 12:01    Post subject:   Reply with quote   

i clear my original problem with downloading PWN backtrak 5 for N900 that have many builtin tools such as WireShark !
But still i can not connect to Nokia Main Repositories because of Nokia Boycott and when i update catalogs it said to me :

Application list partially refreshed.
Some catalogs unavailable.
Check catalog details.

Maybe i must used some tools instead of connecting to socks server .
Thanks for your follow .
Back to top
Ketilk
Site supporter
Site supporter

Please add your avatar!

Joined: 19 Dec 2011

Posts: 506

Thanks received:
50 in 45 posts
Thanks given: 6


Phone: Jolla, N9 , N900, N97-mini

PostPosted: Tuesday, 25.Jun.2013 23:32    Post subject:   Reply with quote   

If tsocks did not work(and you have configured it to use the correct port and ip) then I don't know. Do your socks proxy connect to the TOR-network? Have Nokia N900 started the proxy, or do you have that proxy on another machine?

If you have ssh-access to a computer with non-restricted network, or that route it automatically through TOR, then you might be able to create another socks proxy through ssh. I used ssh to my computer when I got apt-get working through tsocks. I believe ssh-servers are not available for windows, but that they work for anything else.

This command: ssh -D 9999 username@ip-address-of-ssh-server etablishes a socks proxy at localhost using 9999 as port. It will fail if another proxy uses that port.

If you have a socks proxy on another computer, you can forward it to localhost by doing this: ssh user@example.org -L 10000:172.16.10.10:9999. If the remote machine use the port 9999 then you will get access to it at localhost with port 10000.
Back to top

The following users say THANKS! for this post: mbzadegan

mbzadegan
Forum Newbie
Forum Newbie



Joined: 20 Jun 2013

Posts: 12

Thanks received:
0 in 0 posts
Thanks given: 12


Phone: N900

PostPosted: Wednesday, 26.Jun.2013 05:51    Post subject:   Reply with quote   

I have HTTPS/Socks5 account on so.free4ir.com:443 Rolling Eyes
Back to top
Ketilk
Site supporter
Site supporter

Please add your avatar!

Joined: 19 Dec 2011

Posts: 506

Thanks received:
50 in 45 posts
Thanks given: 6


Phone: Jolla, N9 , N900, N97-mini

PostPosted: Wednesday, 26.Jun.2013 15:55    Post subject:   Reply with quote   

That socks proxy is password protected so you will need to configure tsocks in order to authenticate with the proxy.
/etc/tsocks.conf wrote:

server = so.free4ir.com
server_type = 5
server_port = 443

default_user = yourusername
default_pass = yourpassword


You can then use tsocks apt-get update for refreshing your repositories, and install $package with apt-get install $package.

If apt-get update succeeds you can then also make it use it by default. You can also try export LD_PRELOAD=libtsocks.so before you run apt-get update. The LD_PRELOAD variable makes apt-get and any other network application use the tsocks proxy automatically. That does not work for setuid applications though, so I think it won't work for the graphic application manager or any application you use sudo in front of. Either become root, or if you use sudo for becoming root, then use sudo tsocks in front of your command.

The only way of enabling tsocks for setuid applications are risky and might require a reflash of your device if it's done wrong so I won't tell you how to do that. If you don't know what setuid is, or understand the implications of LD_PRELOAD then you should not try the dangerous route.
Back to top

The following users say THANKS! for this post: mbzadegan

mbzadegan
Forum Newbie
Forum Newbie



Joined: 20 Jun 2013

Posts: 12

Thanks received:
0 in 0 posts
Thanks given: 12


Phone: N900

PostPosted: Thursday, 27.Jun.2013 16:54    Post subject:   Reply with quote   

My /etc/tsocks.conf :

path {

server = so.free4ir.com
server_type = 5
server_port = 443
default_user = *******
default_pass = *******
}
server_type = 5

And when i use tsocks apt-get update for refreshing my repositories :

Err http://repository.maemo.org fremantle-1.3/free Packages
Cannot initiate the connection to repository.maemo.org:80 (213.128.137.22). - connect (111 Connection refused)
Err http://repository.maemo.org fremantle-1.3/non-free Packages
Cannot initiate the connection to repository.maemo.org:80 (213.128.137.22). - connect (111 Connection refused)
Err http://repository.maemo.org fremantle/free Packages
Cannot initiate the connection to repository.maemo.org:80 (213.128.137.22). - connect (111 Connection refused)
Err http://repository.maemo.org fremantle/non-free Packages
Cannot initiate the connection to repository.maemo.org:80 (213.128.137.22). - connect (111 Connection refused)
Err http://repository.maemo.org fremantle/free Packages
Cannot initiate the connection to repository.maemo.org:80 (213.128.137.22). - connect (111 Connection refused)
Err http://repository.maemo.org fremantle/non-free Packages
Cannot initiate the connection to repository.maemo.org:80 (213.128.137.22). - connect (111 Connection refused)

Also i repeat this with export LD_PRELOAD=libtsocks.so but this error was repeated ! Sad
How could i do ?! Help
Back to top
Ketilk
Site supporter
Site supporter

Please add your avatar!

Joined: 19 Dec 2011

Posts: 506

Thanks received:
50 in 45 posts
Thanks given: 6


Phone: Jolla, N9 , N900, N97-mini

PostPosted: Thursday, 27.Jun.2013 19:01    Post subject:   Reply with quote   

You have removed the http_proxy and https_proxy settings from the files in /etc/apt/apt.conf.d and the file /etc/apt/apt.conf ? What do you get if you type env|grep http If you use tsocks, then you should not use any other proxy setting.

Have you upgraded to PR1.3 yet? You will have to set up proxies again after upgrading by flashing.
Back to top

The following users say THANKS! for this post: mbzadegan

mbzadegan
Forum Newbie
Forum Newbie



Joined: 20 Jun 2013

Posts: 12

Thanks received:
0 in 0 posts
Thanks given: 12


Phone: N900

PostPosted: Friday, 28.Jun.2013 19:55    Post subject:   Reply with quote   

my /etc/apt/apt.conf.d/ folder have 3 files and every 3 files have not any proxies !
when i typed env|grep http occured nothing .
i am useing last v2 version of pwn (Backtrack for N900) Cool
Back to top
Ketilk
Site supporter
Site supporter

Please add your avatar!

Joined: 19 Dec 2011

Posts: 506

Thanks received:
50 in 45 posts
Thanks given: 6


Phone: Jolla, N9 , N900, N97-mini

PostPosted: Friday, 28.Jun.2013 20:35    Post subject:   Reply with quote   

First, have you run and succeeded using flasher in your other topic? You should do that first if this step is not needed in order to make your backup.

What is the content of your /etc/apt/sources.list.d/hildon-application-manager.list ?

Err http://repository.maemo.org fremantle-1.3/free Packages This line looks like maemo extras repository and Err http://repository.maemo.org fremantle/free Packages looks like maemo extras-devel.

Some guy in #maemo irc-channel says you should not have extras-devel activated when you don't need a specific package from there. He also says that you should not modify sources.list.d manually so if he is right then you should open hildon package manager and disable extras-devel from there. As both of those repositories fails for you then you should disable them both. I am experienced in linux, know my way about harmattan, but I have yet to see whether my linux knowledge and routines breaks maemo or not.

I try to be careful, but some times maemo instructions and common linux routines does not comply completely. I try to keep the experimental routines for myself though so I believe my instructions are safe when they are followed exactly. At least if you use hildon package manager to upgrade your system and/or add/remove software catalogues.
Back to top

The following users say THANKS! for this post: mbzadegan

Display posts from previous:   
Post new topic   Reply to topic    My-Symbian ~ My-Maemo ~ My-MeeGo Forum Index -> Maemo 5 Fremantle All times are GMT + 2 Hours

Go to page
1, 2  Next
Page 1 of 2

 
Jump to:  
View previous topic :: View next topic


Posting/discussing/exchanging warez/cracks/serial numbers/links to web sites offering such resources and/or any other illegal content
is FORBIDDEN on this forum and results in an immediate BAN.


Symbian and all Symbian-based marks and logos are trade marks of Symbian Software Limited.
This website is not in any way endorsed or supported by Symbian Software Limited.    (C) 2001 My-Symbian.com All Rights Reserved